re = /\{\{>\s*\w+\s*\}\}/
str = '<div>
<ul>
<li>{{> name}}</li>
</ul>
<div>{{>footer }}</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end