$re = '/(?:^|\.)\K.*?(?=best)[^\.]*\./m';
$str = 'stack overflow is the best. hello stack.He is the best.
This is the best movie.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);