package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:Block\[)(.*)(?:\]\[value])`)
var str = `Block[first_name][value]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}