$re = '/^(?!.*houl).*ou/m';
$str = 'I shouldn\'t
you should
I know
\'bout time
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);