$re = '/(,\s*[a-z]+)|([a-z]+\s*,)/';
$str = 'red, 1 ,yellow, 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);