$re = '/^(?!.*not).+(?=good)/m';
$str = 'text is good
text is not good
not text is good
text is good not';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);