$re = '/^(?=.*[a-zA-Z])(?=.*\d).{6,}$/m';
$str = 'fooba5
fooba
foo4barere
Ahgd8d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);