#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Gas Commercial Service \([\S\s]+?(?:[\s]+(?:(?:(?:[\w]+ )*)?(?:[\w]+)?Tax:[xX\d\.\%\s]*?\$[\d\.\s]*?\$([\d\.]*)\s*?))(?:[\s]+(?:(?:(?:[\w]+ )*)?(?:[\w]+)?Tax:[xX\d\.\%\s]*?\$[\d\.\s]*?\$([\d\.]*)\s*?))?(?:[\s]+(?:(?:(?:[\w]+ )*)?(?:[\w]+)?Tax:[xX\d\.\%\s]*?\$[\d\.\s]*?\$([\d\.]*)\s*?))?(?:[\s]+(?:(?:(?:[\w]+ )*)?(?:[\w]+)?Tax:[xX\d\.\%\s]*?\$[\d\.\s]*?\$([\d\.]*)\s*?))?(?:[\s]+(?:(?:(?:[\w]+ )*)?(?:[\w]+)?Tax:[xX\d\.\%\s]*?\$[\d\.\s]*?\$([\d\.]*)\s*?))?(?:[\s]+(?:(?:(?:[\w]+ )*)?(?:[\w]+)?Tax:[xX\d\.\%\s]*?\$[\d\.\s]*?\$([\d\.]*)\s*?))?"
Local $sString = " Due Date: 03/13/13" & @CRLF & _
"Electric Commercial Service (E2C)" & @CRLF & _
"Meter Number: 298209" & @CRLF & _
"Reading 02/26/13 91391 Access Chg: 30 days x $0.6324 $18.97" & @CRLF & _
"Reading 01/27/13 90150 Access Chg: 1,241 kWh x $0.0532 $66.02" & @CRLF & _
" 1241 Kilowatt Hours(KWH) Supply Chg: 1,241 kWh x $0.0269 $33.38" & @CRLF & _
"Your average daily usage was 41.37 KWH ECA: 1,241 kWh x $-0.001 $1.24 CR" & @CRLF & _
" Capacity Chg: 1,241 kWh x $0.0012 $1.49" & @CRLF & _
" City Sales Tax: 2.5% x $118.62 $2.97" & @CRLF & _
" County Sales Tax: 1.23% x $118.62 $1.46" & @CRLF & _
" State Sales Tax: 2.9% x $118.62 $3.44" & @CRLF & _
" PPRTA Tax: 1% x $118.62 $1.19" & @CRLF & _
" ECA = Electric Cost Adjustment" & @CRLF & _
" - Making energy-efficiency improvements to your" & @CRLF & _
" business? Save more money with rebates. Visit" & @CRLF & _
" csu.org/business for details." & @CRLF & _
" Total charge this service $127.68" & @CRLF & _
"" & @CRLF & _
"Gas Commercial Service (G1C)" & @CRLF & _
"Meter Number: 73757" & @CRLF & _
"Reading 02/26/13 25459 Access Chg (G1CL): 30 days x $0.7623 $22.87" & @CRLF & _
"Reading 01/27/13 25277 Access Chg (G1CL): 182 CCF x $0.1571 $28.59" & @CRLF & _
" 182 Hundred Cubic Feet(CCF) Gas Cost (G1CL): 182 CCF x $0.6034 $109.82" & @CRLF & _
"Your average daily usage was 6.07 CCF GCA (G1CL): 182 CCF x $-0.17 $30.94 CR" & @CRLF & _
" City Sales Tax: 2.5% X $130.34 $3.26" & @CRLF & _
" County Sales Tax: 1.23% X $130.34 $1.60" & @CRLF & _
" State Sales Tax: 2.9% X $130.34 $3.78" & @CRLF & _
" BullSheet Federal SuperTax: 2.9% X $130.34 $3.78" & @CRLF & _
" PPRTA Tax: 1% X $130.34 $1.30" & @CRLF & _
" - Smell a rotten egg odor at your business? You may" & @CRLF & _
" have a natural gas leak. Leave the premise" & @CRLF & _
" immediately, then call 9-1-1. Emergency crews will" & @CRLF & _
" respond." & @CRLF & _
" Total charge this service $140.28"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")