re = /\b(?:BP:?(?:-Sitting)?|Blood Pressure) \d+\/\d+(?:\/\d+)?(?: ?\d+\/\d+(?:\/\d+)?)*(?: sm| -Lw| cB| Jr|\
-aA| cs| -ic| ic| -RG| kA| -sL| BL| kc| am| -sH| sH| es| ts| np| 8s| ca| Pm| JE| so| cp| v8| Eu| -cp|\
Pm| EB| Fr| -Fr| -ms| -LN| -mT| -mk| -GF| -HO| Jp| wD| 8m| mc| -mc| Yr| -Lp| -ml| -LA| s\/d| -aA| s\/d|mmHg| mm Hg|\
mm hg.)?|B\/P - (?:Sys|Dias)tolic \d+|(?:Sys|Dias)tolic Blood Pressure \d+ \w+\b/m
str = 'Bodu Mass Index 21.5 07/27/18 Blood Pressure 134/78 07/27/18 Position Sitting BP 10/30/17 1345 178/80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end