$re = '/\b(?!abc)(?i:abc)\b/m';
$str = 'abc word abC 3226 aBc aBC Abc AbC ABc ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);