using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""\d+"":)(\d+)(?=[,}])";
string input = @"{""146"":146,""547"":547,""179"":179,""79"":79}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}