import re
regex = re.compile(r"(\/\*+\h*@Desc\([\'\"])(?<desc>.*)([\'\"]\);*)", flags=re.MULTILINE)
test_str = "info : /** @Desc(\"{O}Aucun sondage|]0,Inf[Affiche %start% à %stop% parmi %total% sondage(s).\") **/ Translator.transChoice(\"message.pagination.sondage\", this.length, {'start' : this.pagination.row_start, 'stop':_this.pagination.row_end, 'total': _this.pagination.total}, \"messages\")"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")