$re = '/\d+\s+ok(?!\s+\d+\s+nok)/';
$str = '10 ok
10 ok 2 nok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);