import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(\\(.+\\)).+\\;";
final String string = "STDMETHOD_(void, Method1)(\n"
+ "_Out_writes_to_(gradientStopsCount, _Inexpressible_(\"Retrieved through GetGradientStopCount\") ) D2D1_GRADIENT_STOP *gradientStops,\n"
+ "UINT32 gradientStopsCount) CONST PURE;";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}