import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?),?";
final String string = "3345 Michelson Drive, Suite 400, Irvine, CA 92612\n"
+ "12303 Airport Way, Suite 250, Broomfield, CO 80021\n"
+ "Two North Riverside Plaza, Suite 1430, Chicago, IL 60606\n"
+ "#twentytwo Northumberland Drive, Apostrophe 55, Moon, MN 13145\n"
+ "!Variety Coffe Cup, Potraiture 247, Mars, MS 88888\n"
+ ".* Everywhere, Nowhere 123, Eternity, ET 12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}