# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<Name>)(.*)(<\/Name>)[\n\r]*(<Telephone>)(.*)(<\/Telephone>)"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
"<xxxIPPhoneDirectory clearlight=\"true\">\n\n"
"<Title>Main Directory</Title>\n\n"
"<Prompt>Prompt</Prompt>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Aaron Parks</Name>\n\n"
"<Telephone>7404053585</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Andrea Vogelmeier</Name>\n\n"
"<Telephone>7403343757</Telephone>\n\n"
"<Telephone>7407451052</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Cyndi Corder</Name>\n\n"
"<Telephone>7404041408</Telephone>\n\n"
"</DirectoryEntry>\n"
"<DirectoryEntry>\n\n"
"<Name>Dakotah Scisciani</Name>\n\n"
"<Telephone>7405029443</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Debbie Kallis</Name>\n\n"
"<Telephone>7403349616</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Denise Keefe</Name>\n\n"
"<Telephone>7402434260</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Diana Petro</Name>\n\n"
"<Telephone>7409734464</Telephone>\n\n"
"<Telephone>7403666385</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Ed Hutchison</Name>\n\n"
"<Telephone>7403648351</Telephone>\n\n"
"<Telephone>7405877205</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Eric Hall</Name>\n\n"
"<Telephone>7406444816</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Frank Frye</Name>\n\n"
"<Telephone>7403285924</Telephone>\n\n"
"<Telephone>7403661298</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Gail Shulko</Name>\n\n"
"<Telephone>7407043147</Telephone>\n\n"
"<Telephone>7407871784</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Gretchen Rigsby</Name>\n\n"
"<Telephone>74033640293</Telephone>\n\n"
"<Telephone>7403234308</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Jesse Ours</Name>\n\n"
"<Telephone>7404045337</Telephone>\n\n"
"<Telephone>7409288801</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Jodie Greene</Name>\n\n"
"<Telephone>7409734281</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Kim Thomson</Name>\n\n"
"<Telephone>7405221142</Telephone>\n\n"
"<Telephone>7403443054</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Kyle Hall</Name>\n\n"
"<Telephone>7405045837</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Linda McKee</Name>\n\n"
"<Telephone>7409730214</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Mitch Fellows</Name>\n\n"
"<Telephone>7404039044</Telephone>\n\n"
"<Telephone>7402464724</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Phil Frye</Name>\n\n"
"<Telephone>7404037128</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Ric Lahmers</Name>\n\n"
"<Telephone>7409734462</Telephone>\n\n"
"<Telephone>7407632952</Telephone>\n\n"
"<Telephone>7407632143</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Sharon Holman</Name>\n\n"
"<Telephone>7403348205</Telephone>\n\n"
"<Telephone>7403456949</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Terry Wilson</Name>\n\n"
"<Telephone>7402587296</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<DirectoryEntry>\n\n"
"<Name>Vanessa Beneze</Name>\n\n"
"<Telephone>7404032856</Telephone>\n\n"
"</DirectoryEntry>\n\n"
"<SoftKeyItem>\n\n"
"<URL>http://xxx/minibrowser/start.xml</URL>\n\n"
"</SoftKeyItem>\n\n"
"<SoftKeyItem>\n\n"
"<URL>http://xxx/minibrowser/menu.xml</URL>\n\n"
"</SoftKeyItem>\n\n"
"</xxxIPPhoneDirectory>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.