# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!-0?(\.0+)?(e|$))-?(0|[1-9]\d*)?(\.\d+)?(?<=\d)(e-?(0|[1-9]\d*))?$"
test_str = ("3\n"
"999\n"
"-3\n"
"0\n"
"0.0\n"
"1.0\n"
"0.1\n"
".01\n"
"-0.0000000000000000000000000000000001\n"
"2e3\n"
"-2e3\n"
"2e-3\n"
"-2e-3\n"
"1.0e0\n"
"0.1e1\n"
".01e-1\n"
"-9.1e3\n"
"-9.1e-3\n"
"9E5\n"
"0e-11\n"
"0xff\n"
"0XFF\n"
"0x0\n"
"0xfe3\n"
"0e0\n"
".0e-0\n"
".0e5\n"
".0e-5\n"
"0.0e0\n"
"0.0e123\n"
"0.0e-123\n"
"-0\n"
"-0.0\n"
"-0.0000000000000000000000000000000000\n"
"-.0\n"
"-.0000000000000000000000000000000000\n"
"1xff\n"
"0x\n"
"0x0fg3\n"
"0xf4.\n"
".0xf\n"
"0xfe-3\n"
"-0xff\n"
"0.0xff\n"
"0xff.1\n"
"1e-\n"
"e89\n"
".e3\n"
"001\n"
"-00.2\n"
"6.\n\n"
"f\n"
" -1\n"
"--1\n"
"-.1\n"
"2-\n"
".-1")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.