package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ABC.*?(?:CEC|BCD)`)
var str = `AABCDDDCECCCBCDABCVVVBCD
AABCDDDCECCCABCVVVBCD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}