using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^@:\->!]*)(?:@)([A-Za-z]+)(?:[^@:\->!]*)(?:\:)([0-9]+)(?:[^@:\->!]*)(?:\!+)(A|D)(?:\!+)(?:[^@:\->!]*)(?:->)([0-9]+)(?:[^@:\->!]*)";
string input = @"pp$##@Coruscant:2000000000!D!->5000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}