// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w.*)(-\d*)(_)(\d*)(_)(.*)(\..*)").unwrap();
let string = "M-115_032_St_svetliy.jpg
M-109_064_Zeleniy_RAL_6018_matoviy.jpg
M-109_064_St_svetliy.jpg
RL_07_15_00_096_1024_beliy_RAL_9010_matoviy_beliy_RAL_9010_matoviy.jpg
RL_07_15_00_096_1024_cherniy_RAL_9005_glyanceviy_cherniy_RAL_9005_glyanceviy.jpg
RL_07_15_00_096_1024_Cr_glyanceviy_St_svetliy.jpg
RL_07_15_00_096_1024_St_svetliy_St_svetliy.jpg
FS-043_192_Cr_matoviy.jpg
FS-043_160_Cr_matoviy.jpg
FS-043_192_Cr_glyanceviy.jpg
S-155_096_Ni_nikel.jpg
S-165_128_Ni_nikel.jpg
FS-135_096_olovo_shlifovannoe.jpg
FS-128_128_olovo_shlifovannoe.jpg
FB-025_000_olovo_shlifovannoe.jpg
FB-025_000_bronza_polirovannaya.jpg
FS-162_128_Cr_matoviy_kristalli.jpg
FK-011_010_med_shlifovannaya.jpg
FK-011_020_med_shlifovannaya.jpg
FM-078_032_Cr_glyanceviy_emal_T212801_smoke.jpg
FB-031_000_staroe_olovo_kristall.jpg
FB-031_000_staraya_bronza_kristall.jpg
FB-031_000_bronza_polirovannaya_kristall.jpg
S-165_128_St_svetliy.jpg
FS-140_096_staroe_olovo.jpg
FS-140_064_staroe_olovo.jpg
FS-140_128_staroe_olovo.jpg
FS-128_096_olovo_shlifovannoe.jpg
FM-086_032_staroe_olovo.jpg
FM-086_032_olovo_shlifovannoe.jpg
FM-071_032_staroe_olovo.jpg
FM-105_000_staroe_olovo.jpg
FM-102_000_staroe_olovo.jpg
FS-129_128_staroe_olovo.jpg
FM-088_064_olovo_shlifovannoe.jpg
FS-129_128_olovo_shlifovannoe.jpg
FS-160_096_staroe_olovo.jpg
FM-094_032_staroe_olovo_beliy.jpg
FB-033_000_staroe_olovo_beliy.jpg
FS-141_096B_staroe_olovo_beliy.jpg
FB-026_000_staroe_olovo_beliy.jpg
PM(12)_00_00_096_1024_St_svetliy.jpg
PM(13)_00_00_096_1024_St_svetliy.jpg
RL(05)_18_00_128_1024_St_svetliy_Cr_glyanceviy_kromka-vishnya_mat.jpg
FM-088_064_Cr_glyanceviy.jpg
FM-088_064_bronza_shlifovannaya.jpg
FM-088_064_med_shlifovannaya.jpg
FM-088_064_staraya_med.jpg
FM-088_064_staraya_bronza.jpg
FM-088_064_Zoloto.jpg
FB-025_000_staraya_bronza.jpg
FM-088_064_bronza_polirovannaya.jpg
FS-129_128_bronza_polirovannaya.jpg
FM-064_000_Cr_glyanceviy_emal_farfor_9001.jpg
FM-064_032_Cr_glyanceviy_emal_farfor_9001.jpg
FB-029_000_staroe_olovo_kristal.jpg
FB-030_000_staroe_olovo_kristall.jpg
FS-143_128_staroe_olovo_kristall.jpg
FS-125_064_staroe_olovo_kristal.jpg
FS-125_128_staroe_olovo_kristal.jpg
FB-018_000_staroe_olovo_kristall.jpg
FS-134_096_staroe_olovo.jpg
FS-134_064_staroe_olovo.jpg
FS-139_128_staroe_olovo_beliy.jpg
FS-138_128_staroe_olovo_beliy.jpg
FB-027_000_staroe_olovo_beliy.jpg
FS-141_096_staroe_olovo.jpg
M-108_128_St_svetliy_kromka_venge_matoviy.jpg
FS-159_096_bronza_kristalli.jpg
FS-159_096_Cr_glyanceviy_kristalli.jpg
FS-161_160_Ni_zhemchuzhniy.jpg
FS-161_160_Cr_matoviy.jpg
FS-161_160_metallik_zolotistiy.jpg
FS-163_160_metallik_zolotistiy.jpg
FS-163_160_Cr_matoviy.jpg
FS-163_160_zoloto.jpg
FS-163_160_Cr_glyanceviy.jpg
FK-015_020_St_svetliy_venge_matoviy.jpg
FK-015_010_St_svetliy_venge_matoviy.jpg
FS-160_096_med_shlifovannaya.jpg
FS-160_096_bronza_shlifovannaya.jpg
FS-160_096_staraya_bronza.jpg
FS-160_096_Zoloto.jpg
FS-160_096_Cr_glyanceviy.jpg
FM-105_000_Cr_glyanceviy.jpg
FM-105_000_Cr_Zoloto.jpg
FM-105_000_med_shlifovannaya.jpg
FM-105_000_staraya_bronza.jpg
FM-102_000_Cr_staraya_bronza.jpg
FM-102_000_staraya_med.jpg
FM-102_000_bronza_shlifovannaya.jpg
S-101_128_St_svetliy_kromka_venge_matoviy.jpg
S-101_128_St_svetliy_kromka_buk_matoviy.jpg
S-101_128_St_svetliy_kromka_bvishnya_matovaya.jpg
RL(06)_18_00_128_1024_St_svetliy_Cr_glyanceviy.jpg
RL(05)_10_00_096_1024_St_svetliy_St_svetliy_kromka-vishnya_mat.jpg
FS-161_160_Cr_glyanceviy.jpg
FS-159_128_med_shlifovannaya_kristalli.jpg
FS-159_128_Zoloto_kristalli.jpg
FS-159_128_bronza_polirovannaya_kristalli.jpg
FS-159_128_Cr_matoviy_kristalli.jpg
FS-159_128_Cr_glyanceviy_kristalli.jpg
FS-158_128_staraya_bronza_beliy.jpg
FS-158_128_stal_shlifovannaya_beliy.jpg
FS-158_128_Zoloto_beliy.jpg
FS-158_128_bronza_shlifovannaya_beliy.jpg
FS-158_128_bronza polirovannaya_beliy.jpg
FS-158_128_Ni_zhemchuzhniy_beliy.jpg
FS-112_128_Cr_glyanceviy_kristalli.jpg
FR-009_096_1024_St_svetliy_Cr_glyanceviy.jpg
FB-039_000_staraya_bronza_beliy.jpg
FB-039_000_med_shlifovannaya_beliy.jpg
FB-039_000_Zoloto_beliy.jpg
FB-039_000_bronza_polirovannaya_beliy.jpg
FB-039_000_Cr_glyanceviy_beliy.jpg
FM-102_000_bronza_polirovannaya.jpg
FM-102_000_Zoloto.jpg
FM-062_032_Cr_glyanceviy.jpg
FM-062_032_Cr_glyanceviy_kristalli.jpg
FM-063_064_Cr_glyanceviy_kristalli.jpg
FM-080_064_Cr_glyanceviy_emal_fuksiya_210.jpg
FM-094_096_bronza_polirovannaya_beliy.jpg
FM-104_000_Cr_glyanceviy_kristalli.jpg
FM-104_000_Cr_matoviy_kristalli.jpg
FM-104_000_Ni_zhemchuzhniy_kristalli.jpg
FM-104_000_bronza_polirovannaya_kristalli.jpg
FM-104_000_Zoloto_kristalli.jpg
FM-104_000_med_shlifovannaya_kristalli.jpg
FM-104_000_staraya_bronza_kristalli.jpg
FM-104_000_staraya_med_kristalli.jpg
FM-104_032_Cr_glyanceviy_kristalli.jpg
FM-104_032_Cr_matoviy_kristalli.jpg
FM-104_032_Ni_zhemchuzhniy_kristalli.jpg
FM-104_032_bronza_polirovannaya_kristalli.jpg
FM-104_032_bronza_shlifovannaya_kristalli.jpg
FM-104_032_Zoloto_kristalli.jpg
FM-104_032_med_shlifovannaya_kristalli.jpg
FM-104_032_staraya_bronza_kristalli.jpg
FM-104_032_staraya_med_kristalli.jpg
FM-102_000_Cr_matoviy.jpg
FS-158_128_Cr_glyanceviy_beliy.jpg
FS-158_128_Cr_matoviy_beliy.jpg
FS-158_128_med_shlifovannaya_beliy.jpg
FM-102_000_Cr_glyanceviy.jpg
S-155_096_St_svetliy.jpg
FM-086_032_Zoloto_emal_farfor_9001.jpg
FM-086_032_Cr_glyanceviy_emal_farfor_9001.jpg
FM-086_032_Cr_glyanceviy.jpg
FB-029_000_Zoloto_kristal.jpg
FB-029_000_Cr_glyanceviy_kristal.jpg
FM-092_032_Ni_zhemchuzhniy_beliy.jpg
FM-092_032_staraya_med_beliy.jpg
FM-092_032_med_shlifovannaya_beliy.jpg
FM-092_032_Zoloto_beliy.jpg
FM-092_032_Cr_glyanceviy_beliy.jpg
FM-092_032_Cr_matoviy_beliy.jpg
FM-092_032_bronza_polirovannaya_beliy.jpg
S-156_096_St_svetliy_kromka-venge_matoviy.jpg
FM-094_032_staraya_med_beliy.jpg
FM-094_032_Cr_matoviy_beliy.jpg
FM-094_032_bronza_shlifovannaya_beliy.jpg
FM-094_032_staraya_bronza_beliy.jpg
FM-094_032_Cr_glyanceviy_,beliy.jpg
FM-094_032_Ni_zhemchuzhniy_beliy.jpg
FM-094_032_med_shlifovannaya_beliy.jpg
FM-071_032_Zoloto_emal_chernaya_395.jpg
FM-071_032_Zoloto_emal_farfor_9001.jpg
FM-071_032_Zoloto.jpg
FM-083_032_zhemchuzhniy_Ni.jpg
FM-083_032_hrom_matoviy.jpg
FM-083_032_stal_shlifovannaya.jpg
FM-083_032_bronza_polirovannaya.jpg
FM-083_032_Zoloto.jpg
FM-071_032_staraya_med.jpg
FM-071_032_bronza_shlifovannaya.jpg
FM-071_032_bronza_polirovannaya.jpg
FM-071_032_Cr_glyanceviy.jpg
FM-081_000_stal_shlifovannaya.jpg
FM-081_000_zhemchuzhniy_Ni.jpg
FM-081_000_med_shlifovannaya.jpg
FM-081_000_staraya_med.jpg
FM-081_000_Zoloto_emal_farfor_9001.jpg
FM-081_000_Cr_matoviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg
FM-081_000_Cr_matoviy_emal_farfor_9001.jpg
FM-081_000_Cr_matoviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FM-081_000_Cr_matoviy.jpg
FM-081_000_Cr_glyanceviy_emal_posloynaya_farfor 9001_bescvetnaya_801.jpg
FM-081_000_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FM-081_000_Cr_glyanceviy.jpg
FM-081_000_bronza_shlifovannaya.jpg
FM-081_000_bronza_polirovannaya.jpg
FM-081_000_staraya_bronza.jpg
FM-081_032_med_shlifovannaya.jpg
FS-124_096_staraya_med.jpg
FS-124_096_Zoloto_emal_farfor_9001.jpg
FS-124_096_Cr_matoviy.jpg
FS-124_096_Cr_matoviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FS-124_096_Cr_matoviy_emal_posloynaya_farfor_9001.jpg
FS-124_096_Cr_glyanceviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg
FS-124_096_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FS-124_096_Cr_glyanceviy.jpg
FS-124_096_bronza_polirovannaya.jpg
FM-081_032_staraya_med.jpg
FM-081_032_Zoloto_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg
FM-081_032_Zoloto.jpg
FM-081_032_Cr_matoviy_emal_farfor_9001.jpg
FM-081_032_Cr_matoviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg
FM-081_032_Cr_matoviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FM-081_032_Cr_matoviy.jpg
FM-081_032_Cr_glyanceviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg
FM-081_032_Cr_glyanceviy_emal_chernaya_395.jpg
FM-081_032_Cr_glyanceviy.jpg
FM-081_032_bronza_shlifovannaya.jpg
FM-081_032_bronza_polirovannaya.jpg
FS-132_064_Zoloto.jpg
FS-132_064_med_shlifovannaya.jpg
FS-132_064_zhemchuzhniy_Ni.jpg
FS-132_064_staraya_med.jpg
FS-132_064_staraya_bronza.jpg
FS-132_064_bronza_shlifovannaya.jpg
FS-132_064_Cr_matoviy.jpg
FS-132_064_Cr_glyanceviy.jpg
FS-135_064_Cr_glyanceviy.jpg
FS-135_064_Zoloto.jpg
FS-135_064_staraya_med.jpg
FS-135_064_bronza_shlifovannaya.jpg
FD-028_000_Ni_zhemchuzhniy.jpg
FD-028_000_shlifovannaya_med.jpg
FD-028_000_staraya_med.jpg
FD-028_000_Zoloto.jpg
FD-028_000_Cr_matoviy.jpg
FD-028_000_Cr_glyanceviy.jpg
FD-028_000_bronza_shlifovannaya.jpg
FD-028_000_bronza_polirovannaya.jpg
FD-030_000_Ni_zhemchuzhniy.jpg
FD-030_000_Cr_matoviy.jpg
FD-030_000_Cr_glyanceviy.jpg
FD-030_000_bronza_shlifovannaya.jpg
FD-030_000_bronza_polirovannaya.jpg
FD-030_000_staraya_bronza.jpg
FD-030_000_Zoloto.jpg
FB-030_000_Zoloto_kristall.jpg
FB-031_000_Zoloto_kristall.jpg
FS-138_128_Zoloto_beliy.jpg
FS-140_128_Cr_glyanceviy.jpg
FS-140_128_Zoloto.jpg
FS-140_096_Zoloto.jpg
FS-140_096_bronza_polirovannaya.jpg
FS-140_064_Zoloto.jpg
FS-140_064_Cr_glyanceviy.jpg
FS-140_064_bronza_polirovannaya.jpg
FS-135_096_Zoloto.jpg
FS-135_096_Cr_glyanceviy.jpg
FS-111_128_zhemchuzhniy_Ni.jpg
FS-111_128_Cr_glyanceviy.jpg
FS-122_128_staraya_bronza_emal_farfor_9001.jpg
FS-122_128_Cr_glyanceviy_emal_farfor_9001_emal_aliy_363.jpg
FM-078_032_staraya_bronza_emal_farfor_9001.jpg
FM-078_032_Cr_glyanceviy_emal_farfor_9001_emal_krasnaya_3063.jpg
FS-121_128_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FM-077_000_staraya_bronza.jpg
FM-077_000_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FM-071_032_Cr_glyanceviy_emal_posloynaya_slonovaya_kost_9002_bescvetnaya_801.jpg
FM-071_032_Zoloto_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg
FM-094_032_Zoloto_beliy.jpg
FS-141_096_bronza_polirovannaya.jpg
FS-141_096_Zoloto.jpg
FS-141_096B_Zoloto_beliy.jpg
FS-141_096B_bronza_polirovannaya_beliy.jpg
FB-033_000_Zoloto_beliy.jpg
FS-142_096_zhemchuzhniy_Ni_kristall.jpg
FS-142_096_Zoloto_kristall.jpg
FS-143_128_Zoloto_kristall.jpg
FB-027_000_Zoloto_beliy.jpg
FS-139_128_Zoloto_beliy.jpg
FS-135_064_staraya_bronza.jpg
FB-028_064_staraya_bronza.jpg
FS-131_128_Cr_glyanceviy.jpg
FS-131_128_staraya_bronza.jpg
FS-135_096_staraya_bronza.jpg
FS-111_128_staraya_bronza.jpg
FS-122_128_Zoloto_emal_bruno_T475.jpg
FS-122_128_Cr_glyanceviy_emal_fuksiya_210.jpg
FM-078_032_Zoloto_emal_bruno_T475.jpg
FM-077_000_Cr_glyanceviy_emal_chernaya_395.jpg
FM-077_000_Zoloto_emal_chernaya_395.jpg
FS-121_128_Zoloto_emal_chernaya 395.jpg
FS-121_128_Cr_glyanceviy_emal_chernaya 395.jpg
FS-121_128_staraya_bronza.jpg
FB-033_000_bronza_polirovannaya_beliy.jpg
FM-094_032_bronza_polirovannaya_beliy.jpg
FS-141_096B_staraya_bronza_beliy.jpg
FS-141_096_staraya_bronza.jpg
FS-043_192_Cr_glyanceviy_emal_395_chernaya.jpg
FS-043_128_Cr_glyanceviy_emal_395_chernaya.jpg
FS-043_160_Cr_glyanceviy_emal_395_chernaya.jpg
FB-018_000_Zoloto_kristall.jpg
FS-142_096_Cr_glyanceviy_kristall.jpg
FB-031_000_Cr_glyanceviy_kristall.jpg
FB-031_000_zhemchuzhniy_Ni_kristall.jpg
FS-142_096_bronza polirovannaya_kristall.jpg
FS-131_128_bronza_shlifovannaya.jpg
FS-157_096_bronza_shlifovannaya.jpg
FS-157_096_bronza_polirovannaya.jpg
FS-144_096_Cr glyanceviy.jpg
FS-144_096_Zoloto.jpg
FS-144_096_staraya_bronza.jpg
FS-144_096_staraya_med.jpg
FS-144_096_med_shlifovannaya.jpg
FS-144_096_bronza_shlifovannaya.jpg
FS-152_096_bronza_shlifovannaya.jpg
FB-036_000_staraya_bronza.jpg
FB-036_000_bronza_polirovannaya.jpg
FS-154_096_bronza_shlifovannaya.jpg
FS-154_096_bronza_polirovannaya.jpg
FS-154_096_Cr_matoviy.jpg
FS-154_096_Cr_glyanceviy.jpg
FB-036_000_Cr_glyanceviy.jpg
FB-036_000_med_shlifovannaya.jpg
FS-152_096_med_shlifovannaya.jpg
FS-152_096_bronza polirovannaya.jpg
FS-152_096_staraya_med.jpg
FB-035_000_staraya med.jpg
FB-035_000_Zoloto.jpg
FB-035_000_Cr_glyanceviy.jpg
FB-035_000_bronza_polirovannaya.jpg
FB-037_000_med_shlifovannaya.jpg
FB-037_000_Cr_glyanceviy.jpg
FM-086_032_Zoloto_emal_bruno_T475.jpg
FS-128_096_Zoloto_emal_bruno_T475.jpg
FB-019_000_Zoloto_emal_bruno_T475.jpg
FS-115_096_med_shlifovannaya_beliy_kristall.jpg
FS-115_096_staraya_bronza_beliy_kristall.jpg
FS-115_096_Cr_matoviy_beliy_kristall.jpg
FS-115_096_Zoloto_beliy_kristall.jpg
FN-001_000_staraya_med.jpg
FN-004_000_staraya_bronza.jpg
FN-002_000_staraya_bronza.jpg
FN-003_000_staraya_bronza.jpg
FS-143_128_Cr_glyanceviy_kristall.jpg
FB-030_000_Cr_glyanceviy_kristall.jpg
FS-138_128_bronza_polirovannaya_beliy.jpg
FS-138_128_Cr_glyanceviy_beliy.jpg
FB-027_000_Cr_glyanceviy_beliy.jpg
FB-027_000_bronza_polirovannaya_beliy.jpg
FS-128_128_Zoloto_emal_bruno_T475.jpg
FS-123_128_Zoloto_emal_bruno_T475.jpg
FM-087_032_Zoloto_emal_bruno_T475.jpg
FS-139_128_bronza_polirovannaya_beliy.jpg
FS-139_128_Cr_glyanceviy_beliy.jpg
FB-026_000_Cr_glyanceviy_beliy.jpg
FB-026_000_bronza_polirovannaya_beliy.jpg
FB-026_000_Zoloto_beliy.jpg
S-153_096_St_svetliy_kromka-vishnya_matovaya.jpg
S-150_128_St_svetliy_kromka-vishnya_matovaya.jpg
S-149_128_St_svetliy_kromka-buk_matoviy.jpg
S-146_128_St_svetliy_kromka-buk_matoviy.jpg
S-148_128_St_svetliy_kromka-venge_matoviy.jpg
S-148_096_St_svetliy_kromka-venge_matoviy.jpg
B-034_000_St_svetliy_kromka-venge_matoviy.jpg
S-145_128_St_svetliy_kromka-venge_matoviy.jpg
FS-128_128_bronza_polirovannaya.jpg
FS-128_096_bronza_polirovannaya.jpg
FS-125_160_Cr_glyanceviy_kristalli.jpg
FS-125_160_bronza_polirovannaya_kristalli.jpg
FS-125_160_Zoloto_kristall.jpg
FS-125_128_Zoloto_kristalli.jpg
FS-125_128_Cr_glyanceviy_kristalli.jpg
FS-125_128_polirovannaya_bronza_kristalli.jpg
FS-123_128_bronza_polirovannaya.jpg
FS-115_096_zhemchuzhniy_Ni_beliy_kristall.jpg
FS-115_096_staraya med_beliy_kristall.jpg
FS-115_096_Cr_glyanceviy_beliy_kristall.jpg
FM-087_032_bronza_polirovannaya.jpg
FM-086_032_bronza_polirovannaya.jpg
FS-126_160_Cr_glyanceviy.jpg
FM-083_032_Cr_glyanceviy.jpg
FD-031_000_bronza polirovannaya_belie kristalli.jpg
FB-019_000_bronza_polirovannaya.jpg
FB-018_000_bronza_polirovannaya_kristall.jpg
FB-018_000_Cr_glyanceviy_kristall.jpg
FD-031_000_Cr_glyanceviy_belie kristalli.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}