package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A
(?> #MAIN iteration (atomic only for efficiency)
(?<upper>[A-Z]) # an uppercase letter
| # or
(?<lower>[a-z]) # a lowercase letter
| # or
(?<digit>[0-9]) # a digit
| # or
. # anything else
){8,}? #REPEATED 8+ times
#
#CONDITIONS:
(?(upper) # 1. There must be at least 1 uppercase
(?(lower) # 2. If (1), there must be 1 lowercase
(?(digit) # 3. If (2), there must be 1 digit
| (?!) # Else fail
) #
| (?!) # Else fail
) #
| (?!) # Else fail
) #`)
var str = `1Bc45678`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}