$re = '/\d*\.\d+/';
$str = '12/35.6+=123.5.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);