$re = '/(^[A-Z\s?]{1,21}$)/';
$str = 'AASDF AASDF ASDAS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);