import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\w+-\\d+-\\d+(?:[,.\\-0-9A-Z]+)?\\s+.*?(?=\\n\\n|\\n+\\Z|\\Z))";
final String string = "34A-6-87.1 Disposal of tire waste--Collection or processing sites--Penalties for violations.\n"
+ " 34A-6-87.1. Disposal of tire waste--Collection or processing sites--Penalties for violations. Any person hauling or transporting any waste tire as defined in subdivision 34A-6-61(25), originating from a wholesaler or retailer shall ensure the proper disposal of the waste tire at a department approved waste tire collection or processing site, or that it is used in some other manner approved by the department. The board may promulgate rules, pursuant to chapter 1-26, setting forth the requirements and procedures for department approval of waste tire collection, processing sites, or other approved uses for waste tires. Any waste tire hauler or transporter who intentionally disposes of any waste tire in a manner inconsistent with the provisions of this section is subject to a civil action by the State of South Dakota in circuit court for the recovery of a civil penalty of not more than ten thousand dollars per day per violation, or for costs to clean up sites not approved, or both. The violator is also subject to the criminal penalties provided for in § 34A-6-87.\n"
+ "Source:\n"
+ " SL 1998, ch 202, § 1. Source:\n\n"
+ "34A-6-8-2A Transferred.\n"
+ " 34A-6-88. Transferred to § 46A-1-83.1.\n\n"
+ "34A-6-8-2A Transferred.\n"
+ " 34A-6-88. Transferred to § 46A-1-83.1.\n\n"
+ "34A-6-88, Transferred.\n"
+ " 34A-6-88. Transferred to § 46A-1-83.1.\n\n"
+ "34A-6-88 to 23-34-1A Transferred.\n"
+ " 34A-6-88. Transferred to § 46A-1-83.1.\n\n"
+ "34A-1-28 Repealed.\n"
+ " 34A-1-28. Repealed by SL 1986, ch 295, § 7.\n\n"
+ "34A-1-28 Repealed.\n"
+ " 34A-1-28. Repealed by SL 1986, ch 295, § 7.\n\n"
+ "34A-6-89-34 Scale device required--Records--Report--Contents--Permit for longer capacity disposal.\n"
+ " 34A-6-89. Scale device required--Records--Report--Contents--Permit for longer capacity disposal. Any solid waste facility permitted to dispose of solid waste in excess of one hundred thousand tons per year shall be equipped with a scale device, approved by the Department of Public Safety, and shall weigh and maintain records of the total amount of solid waste disposed of at the facility. On or before the fifteenth of each month, the facility shall submit to the department a report upon such forms as may be prescribed by the department in rules promulgated pursuant to chapter 1-26. The report shall state the total amount of solid waste disposed of at the facility in the preceding month. The forms shall contain a sworn certification by the owner or operator that the information contained in the monthly report is true and correct based upon his own best information, knowledge, and belief. No facility may dispose of solid waste in excess of one hundred fifty thousand tons per year without a permit authorizing the capacity of the facility to dispose of solid waste in such quantities as provided in § 34A-6-1.16.\n"
+ "Source:\n"
+ " SL 1992, ch 254, § 50Q; SL 2004, ch 17, § 231. Source:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}