import Foundation
let pattern = #"%%answer_([0-9]+)%%"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Chère Perle,Merci d'avoir pris le temps de répondre aux questions d'introspection de votre parcours BOAD au féminin. Vos réponses sont précieuses et reflètent votre profondeur de réflexion.
Il est inspirant de constater que vous avez identifié %%answer_31%% comme une de vos principales forces. Votre %%answer_31%% vous distingue indéniablement des autres et cela vous servira indéniablement dans votre objectif de développement. Votre détermination et votre capacité à faire preuve d'empathie seront des atouts majeurs pour surmonter les défis et saisir les opportunités qui se présenteront à vous.
Les trois valeurs essentielles que vous avez identifiées, %%answer_32%% , sont clairement au cœur de vos choix et de vos actions. Elles vous guideront avec intégrité dans votre parcours de développement, vous aidant ainsi à prendre des décisions alignées avec vos convictions profondes.
En ce qui concerne votre future carrière, il est inspirant de voir que vous avez déjà en tête un emploi de rêve qui vous épanouirait pleinement. Votre vision de succès retentissant vous permettra certainement de tracer une trajectoire prometteuse vers la réalisation de vos aspirations professionnelles.
Votre réponse sur ce qui vous manquerait le plus sur une île déserte, %%answer_34%% , reflète l'importance que vous accordez aux liens humains et à votre connexion avec les autres. Cette prise de conscience renforce l'importance de la communication et de l'établissement de relations significatives dans votre objectif de développement personnel.
Quant à vos accomplissements, ceux que vous souhaitez transmettre à vos enfants ou futurs enfants, %%answer_35%% , montrent votre désir de laisser un héritage inspirant. Vos succès professionnels et personnels seront une source d'inspiration pour les générations futures.
%%answer_344587414145%%
Enfin, vos réflexions sur les différents exposés et leur impact sur la réalisation de votre objectif de développement démontrent votre ouverture d'esprit et votre volonté de tirer des enseignements précieux de chaque opportunité d'apprentissage. Ce processus d'apprentissage continu vous aidera à vous adapter aux défis en cours de route et à progresser vers la réalisation de vos aspirations.
Encore une fois, nous vous remercions de votre participation et de votre introspection approfondie. Nous avons hâte de vous retrouvez dans la carte 3 de votre parcours BOAD au féminin.
Meilleures salutations,
L’équipe perle de Leader
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)