$re = '/^(?! )(?!.* $)(?!(?:.* ){2}).*$/m';
$str = 'test1
test 2
test3
test4
te st 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);