import re
regex = re.compile(r"(\([A-Z]+\)[^$]*\$[^$]*\$[,\d]+)(?:(?:\n(?!.*\([A-Z]+\)[^$]*\$[^$]*\$[,\d]|D:).*)*\n(D:.*))?", flags=re.MULTILINE)
test_str = ("JT Meta Platforms, Inc. - Class A\n"
"Common Stock (META) [ST]S (partial) 02/08/2024 03/05/2024 $1,001 - $15,000\n"
"F S: New\n"
"S O: Morgan Stanley - Select UMA Account # 1\n"
"JT Microsoft Corporation - Common\n"
"Stock (MSFT) [ST]S (partial) 02/08/2024 03/05/2024 $1,001 - $15,000\n"
"F S: New\n"
"S O: Morgan Stanley - Select UMA Account # 1\n"
"JT Microsoft Corporation - Common\n"
"Stock (MSFT) [OP]P 02/13/2024 03/05/2024 $500,001 -\n"
"$1,000,000\n"
"F S: New\n"
"S O: Morgan Stanley - Portfolio Management Active Assets Account\n"
"D: Call options; Strike price $170; Expires 01/17 /2025\n"
"C: Ref: 044Q34N6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")