$re = '~(?:\G(?!\A)|Hi\s*)
(?P<name>[A-Z][^,\n\r]+)
(?:,\h)?~x';
$str = '
Hi Marc, Stefanie El, Paul
Congrats on the new job!
I hope you’re feeling better this morning!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);