re = /(?<=: )(.+)(?= Repeat:|$)/
str = '20:30-22:30 13.05.2015: Manfred treffen Repeat: FREQ=WEEKLY;BYDAY=WE;WKST=MO
09.05. - 12.05.2015: Britt Besuch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end