$re = '/^[a-zA-Z0-9][\w-]*$/m';
$str = 'Web_site-1-2
Web_site
_Website1
1_WebSite
-Web_site';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);