re = /(?<=>)[a-zA-Z]+(?=\W*<)/m
str = '<h4 id="Foobar:">Foobar:</h4>
<h1 id="Monty">Python<a href="https://..."></a></h1>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end