#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(/[^:" ()]+\..[^: "()]+):-?(\d.*?):(\d.*)?.*?((?:warning|error|note): (?:(?![\r\n]{2})[\s\S])+)"
Local $sString = "Build failed: Command failed with exit code 1." & @CRLF & _
"stderr: /sample/path/to/SampleFile.java:1: error: [PackageLocation] Expected package /sample/path/to/ to be declared in a directory ending with /sample/path/to, instead found /sample/path/To" & @CRLF & _
"package sample.path.to;" & @CRLF & _
"" & @CRLF & _
" (see http://errorprone.info/bugpattern/PackageLocation)" & @CRLF & _
"/sample/path/to/SampleFile2.java:-1: note: Some input files use or override a deprecated API." & @CRLF & _
"" & @CRLF & _
"/sample/path/to/SampleFile2.java:-1:6 note: Recompile with -Xlint:deprecation for details."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")