package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z0-9_+&*-]+(?:\.[a-zA-Z0-9_+&*-]+)*@(?:[a-zA-Z0-9-]+\.)+[a-zA-Z]{2,24}`)
var str = `foo@bar.com
foo.bar@bar.com
foo.going@bar.museum`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}