re = /.*\/.*\/(.*)?.*\?.*/
str = '/auth/json/pearson/sessions/afhasjghdjghjdfh****?_action=validate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end