$re = '/^[^\W\d]*$/um';
$str = 'Dąb
Dąb12
1245
Number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);