#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)/^test:.*$/m"
Local $sString = "Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189" & @CRLF & _
"test: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189" & @CRLF & _
"Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189" & @CRLF & _
"Resolve: SECAP-3173, SECAP-3139, SECAP-3147, SECAP-3189"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")