re = /^\s*[A-Za-z0-9]+(?:\s+[A-Za-z0-9]+)*\s*$/m
str = ' Test this stuf
Test
Test '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end