$re = '/([0-9])\\\\(\w+)\\\\(\w+)\\\\((\w+\s+\w+\s+\w+)|\w+\s\w+|\w+)\\\\([+-]?\d*\.\d+)(?![-+0-9\\\\.])/m';
$str = '2\\James\\Brown\\Football Club Mu\\15.45\\1\\Jessie\\Ellis\\Football Club Performance\\15.48\\4\\Dane\\Brown\\FC Football \\15.52\\5\\Richardo\\Flemmings\\Football Club Striders\\15.53\\7\\Lawrence\\Brown\\Football Club Testing\\15.53\\8\\Jermy\\Black\\Football Club Ch\\15.34
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);