#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\d\d)(?![a-zA-Z]{2})(?:(?:>?[:;=%8BXx]['‘’]?[-o*,^ã£]?(?:(?P<mouth>[()|Il])(?P=mouth)*|[\/0\]o\\D\[PpSs<>{}CcOXx*3@ÞþbL&?$#]))|(?:[()\\{}\/<\[>\]DOo0|SsXxlI*@q][-o*,]?['‘’]?[:=8;%Xx]<?))|(?P<head>\()?(?:(?P<eye>[<>v*.^~=ಠ-])?[_.-](?P=eye)|[o0O][_.-][o0O]|>[_.-]?<)['‘’]?(?(head)\))|xD|XD|XP|xP|DX|<3|\^\^|\\o\/|o\/|\\o"
Local $sString = ":-) :) :D :o) :] :3 :c) :> =] 8) =) :} :^) :ã£)" & @CRLF & _
":-D 8-D 8D x-D xD X-D XD =-D =D =-3 =3 B^D" & @CRLF & _
":-))" & @CRLF & _
">:[ :-( :( :-c :c :-< :ã£C :< :-[ :[ :{" & @CRLF & _
";(" & @CRLF & _
":-|| :@ >:(" & @CRLF & _
":'-( :'(" & @CRLF & _
":'-) :')" & @CRLF & _
"D:< D: D8 D; D= DX v.v D-':" & @CRLF & _
">:O :-O :O :-o :o 8-0 O_O o-o O_o o_O o_o O-O" & @CRLF & _
":* :^* ( '}{' )" & @CRLF & _
";-) ;) *-) *) ;-] ;] ;D ;^) :-," & @CRLF & _
">:P :-P :P X-P x-p xp XP :-p :p " & @CRLF & _
"=p :-Þ :Þ :þ :-þ :-b :b d:" & @CRLF & _
">:\ >:/ :-/ :-. :/ :\ =/ =\ :L =L :S >.<" & @CRLF & _
":| :-|" & @CRLF & _
":$" & @CRLF & _
":-X :X :-# :#" & @CRLF & _
"O:-) 0:-3 0:3 0:-) 0:) 0;^)" & @CRLF & _
">:) >;) >:-)" & @CRLF & _
"}:-) }:) 3:-) 3:)" & @CRLF & _
"o/\o ^5 >_>^ ^<_<" & @CRLF & _
"|;-) |-O" & @CRLF & _
":-& :&" & @CRLF & _
"#-)" & @CRLF & _
"%-) %)" & @CRLF & _
"<:-|" & @CRLF & _
"ಠ_ಠ" & @CRLF & _
"\o/" & @CRLF & _
"*\0/*" & @CRLF & _
"(>_<)" & @CRLF & _
"~_~" & @CRLF & _
"-.-'" & @CRLF & _
"(=_=)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")