$re = '/(?<=title\=\")\d+-\d+-\d+/im';
$str = '<html>
<body>
title="2010-09-11 11:22:45Z"
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);