$re = '/[\p{L}\p{M}]+/i';
$str = '熏肉еконcarácterbañlácaractères';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);