$re = '/^[0-9]+(M?[RS])?$/m';
$str = '20S
20R
20MS
20MR
20
20M';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);