re = /'([^\\']*(?:\\.[^\\']*)*)'|"([^\\"]*(?:\\.[^\\"]*)*)"/m
str = '\'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar \'foo \\\'bar bar\\\' baz\' bar \'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar \'foo \\\'bar bar\\\' baz\' bar \'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar \'foo \\\'bar bar\\\' baz\' bar \'foo bar baz\' foo barbar baz "foo bar \\"baz foo\\" bar baz" foo bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end