package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\$([^.{}]+(?:\.[^.{}]+)+)\}`)
var str = `Welcome {$user.first_name} to the {$site} version 1.5. Your username is {$user.username}. Your reputation at present is {$user.reputation.name}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}