const regex = /(?<=;)"([^"]*)"(?=;)|([^;]+);?|;/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=;)"([^"]*)"(?=;)|([^;]+);?|;', 'sg')
const str = `11221;"9 Test with ; semicolon";TST03;6011
48350;;;1919
48350;10 Test Reference *;;
23001;"Hello " Hello";"1234";4506
23001;Hello; " Hello";"1234";4506
BCNR_HEADQUARTERS_BANK;MERCHANT_NAME;MERCHANT_ID;MCC
80000;1 Fix Merchant Name;;
80000;2 *GUIMY0801C;300293199;
23000;3 * Merchant Name;;6011
23000;4Fix Merchant*;;6010
80000;5 MY1901000C\\**;45;6011
80000;6 Test Reference DY0800011C;300293199;
77800;7 Multiple "quotation" "marks;TST01;
78700;8 Special chars /*-+\`?=)(/&%ç*"+;TST02;6010
BCNR_HEADQUARTERS_BANK;MERCHANT_NAME;MERCHANT_ID;MCC
80000;1 Fix Merchant Name;;
80000;2 *GUIMY0801C;300293199;
23000;3 * Merchant Name;;6011
23000;4 Fix Merchant*;;6010
80000;5 MY1901000C\\**;45;6011
80000;6 Test Reference DY0800011C;300293199;
77800;7 Multiple "quotation" "marks;6543;
78700;8 Special chars /*-+\`?=)(/&%ç*"+;9999;6010
11221;"9 Test with ; semicolon";9999;6011
48350;10 Test Reference *;;
23001;"11 Escape char " which must not be interpreted";"MERID";4506
-- https://regex101.com/r/5b2Lsx/1
-- https://regex101.com/r/MnZLSH/1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}