using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(.+)\1)([\[\\\]]){256}$";
string input = @"[\[][\][]\[\][\[][\][]\[][\[]\[\][\[][\][]\[\][\[]\[\][]\[][\[]\[\][\[][\][]\[\]\[][\[]\[\][\[][\][]\[][\[]\[\][\[][\]\[\][\[]\[\][]\[][\[]\[\][\[][\][]\[\][\[]\[\][]\[][\[]\[\][\[][\]\[\][\[]\[\][]\[][\[]\[\][\[]\][\]\[\][\[][\][]\[\][\[][\]\[\][\[]\[\][]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}