package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[(?:[^[\]]++|(?1))*\])|<[^>]*>|'[^']*'|[!-~]+`)
var str = `<As's\\as'dsd> asqwedasd <sa sdasd> [a sadasd] [<asdsad> [as ddsd]] 'asdsad assd'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}