import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "::(\\w+)[^::]+::(?<content>.*?)::(?=\\/\\1)";
final String string = "::cck_gx::gx::/cck_gx::\n"
+ "::i1|0|gx::Lorem::/i1|0|gx::\n"
+ "::head1|0|gx::ipsum::/head1|0|gx::\n"
+ "::tx1|0|gx::dolor, fithos lusec.::/tx1|0|gx::\n"
+ "::cckend_gx::::/cckend_gx::\n"
+ "::cck_gx::gx::/cck_gx::\n"
+ "::i1|1|gx::calendar::/i1|1|gx::\n"
+ "::head1|1|gx::1 Fatura Grátis Por Ano::/head1|1|gx::\n"
+ "::tx1|1|gx::10% de cada mensalidade é reservado, e o valor acumulado até a renovação do Seguro Porto Seguro ou Azul Seguros, é devolvido em forma de desconto. Ou seja, Cliente Conecta pode ter uma fatura de celular grátis por ano.::/tx1|1|gx::";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}