package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\(\d+\.\d+\))$`)
var str = `Doc2-example(2.2)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}