package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((1\s?)?(\d{3}|\(\d{3}\)))[\-|\s]?\d{3}[\-|\s]?\d{4}$`)
var str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1 456 789 4444
//fail
//
1(555)555-5555
1 555)555-5555
123**&!!asdf#
55555555
(6505552368)
2 (757) 622-7382
0 (757) 622-7382
-1 (757) 622-7382
2 757 622-7382
10 (757) 622-7382
27576227382
(275)76227382
2(757)6227382
2(757)622-7382
555)-555-5555
(555-555-5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}